31 May 2023

Diagram Gantta do prowadzenia projektów

Excel jako narzędzie „do wszystkiego” bardzo często wykorzystywany jest do prowadzenia projektów. Niestety wśród jego całej gamy funkcjonalności brak narzędzia które narysuje nam diagram Gantta.

Diagram Gantta do prowadzenia projektów
theme-w-ico
theme-ico

Opis filmu

Oczywiście istnieją płatne dodatki uzupełniające tą funkcjonalność oraz mniej lub bardziej udane obejścia tego problemu. Ja chciałbym Wam dziś pokazać jak stworzyć sobie własny szablon zarządzania projektami w formacie Gantta za pomocą prostych funkcji i formatowania warunkowego.

Jako podstawę przygotowałem sobie arkusz zawierający niezbędne nagłówki kolumn sformatowane w przyjazny dla oka sposób oraz pierwszy tydzień roboczy kalendarza.

 

……………………..

 

.

 

Kolumny

  • Poprzednik (Lp zadania poprzedniego)
  • Zadanie

Będziemy wypełniać ręcznie więc pozostawiamy je puste

Kolumny

  • Status
  • Osoba

Będziemy wybierać z listy wartości które wpisałem sobie do arkusza Stałe w dwóch tabelkach

 

 

 

 

Stajemy wiec w komórce C4 i wybieramy Menu Dane -> Poprawność danych następnie wybieramy Dozwolone = Lista oraz jako Źródło wskazujemy kolumnę tabeli ze Statusami

 

 

 

 

Analogiczne czynności wykonujemy dla komórki E4 z tym że w Źródło wskazujemy kolumnę tabeli z Osobami.

W pozostałe kolumny wpiszemy funkcje i tak:

  • Lp – komórka A4=JEŻELI(D4<>””;MAX(A$3:A3)+1;””) nadaje kolejne numery wierszom w których jest wpisana nazwa zadania
  • Data rozpoczęcia – komórka F4= JEŻELI(B4>0;X.WYSZUKAJ(B4;A:A;G:G);JEŻELI(D4<>””;DZIŚ();””))jeżeli jest wpisany poprzednik wpisuje jego datę zakończenia a jeżeli nie to datę dzisiejszą o ile jest wpisane zadane. Przy czym zakładamy że w razie potrzeby wpisujemy datę ręcznie
  • Data zakończenia – komórka G4 = F4 data końca jest analogiczna jak data początku przy czym zakładamy że zmieniamy ją ręcznie lub dodajemy do niej X dni trwania zadania
  • Pierwszy dzień kalendarza – komórka H4=JEŻELI(ORAZ(H$2>=$F4;H$2<=$G4);PRZEŁĄCZ($C4;”Nie rozpoczęte”;1;”W realizacji”;2;”Zakończone”;3;0);0) formuła wpisuje 0 jeżeli data kolumny jest różna od okresu danego zadania oraz wartości 1,2 lub 3 zależne od statusu zadania jeżeli data mieści się w jego okresie
  • Dni kalendarza – komórka M1=H1 jak tydzień wcześniej
  • Daty kalendarza – komórka M2=H2+7 tydzień wcześniej +7 dni

Teraz pozostaje skonfigurować formatowanie warunkowe zależne od wartości danej komórki.

Zaznaczamy komórkę H4 i wybieramy Menu Narzędzia główne -> Formatowanie Warunkowe -> Nowa reguła a następnie Formatuj tylko komórki zawierająceWartość komórkirówna0 jak w poniższym okienku

 

 

 

Następnie wybieramy Formatuj i w zakładce Wypełnienie kolor biały oraz w zakładce Czcionka również kolor biały

Teraz powtarzamy wszystkie powyższe czynności formatowania warunkowego wpisując wartość 1 i kolor np. czerwony, wartość 2 i kolor np. niebieski oraz wartość 3 i kolor np. zielony

Po poprawnym wykonaniu wszystkich czynności wybierając Menu Narzędzia główne -> Formatowanie warunkowe -> Zarządzaj regułami powinniśmy zobaczyć poniższy obraz

 

 

Aby nasz arkusz działał w całości rozciągamy komórki w szerz M1 i M2 tak daleko w prawo jak długi potrzebujemy harmonogram, H4 tak daleko w prawo jak M1 i M2, i na koniec obszar A2 do końca naszego kalendarza w dół tak daleko jak potrzebujemy

Pozostaje nam przetestować efekt naszej pracy: wpisujemy nazwy zadań, wybieramy osoby odpowiedzialne, uzupełniamy poprzedniki oraz wpisujemy daty zakończenia zdań lub uzupełniamy je o czas trwania zadania w dniach. Po wybraniu statusów zadań powinniśmy uzyskać efekt podobny do poniższego

 

 

Mam nadzieję, że wykorzystacie zaproponowane rozwiązanie jako podstawę do jego dalszego rozwoju i uda wam się skutecznie prowadzić swoje projekty przy pomocy Excela.

Gdybyście w swojej pracy potrzebowali bardziej rozbudowanych narzędzi lub mieli inne zagadnienia związane z prezentacją danych w wybrany przez siebie sposób zapraszam do kontaktu na adres  konrad.pogodz@itch.pl

 

 

 

Pobierz darmowy materiał szkoleniowy:

Dzielimy się
wiedzą

Nasza Firma zapewnia nie tylko najnowsze rozwiązania z dziedziny IT ale również nie pozostaje w miejscu każdego dnia poszerza swoją wiedzę którą bardzo chętnie dzielimy się z innymi. Zapraszamy do zapoznania się z ostatnimi nowinkami.

theme-w-ico
arrows-ico-wh
Imię i Nazwisko łączenie, rozdzielanie, zamiana kolejności

Z doświadczenia wiem, że często powtarzającym się problemem jest obróbka imion i nazwisk. Czy powinny być w dwóch kolumnach czy w jednej i w jakiej kolejności ?

theme-w-ico
arrows-ico-wh
POWER APPS – AUDYT część 4

Zapraszamy na ostatni odcinek instrukcji tworzenia w Power Apps aplikacji umożliwiającej audytowanie dowolnych procesów przedsiębiorstwa.

theme-w-ico
arrows-ico-wh
POWER APPS – AUDYT część 3

Zapraszam na trzeci odcinek instrukcji tworzenia w Power Apps aplikacji umożliwiającej edytowanie dowolnych procesów przedsiębiorstwa.

 

theme-w-ico
theme-ico

Poznajmy się
i porozmawiajmy!

arrows-b

Skontaktuj się z nami i otwórz drzwi do innowacyjnych rozwiązań technologicznych dla Twojej firmy. Nasz zespół ekspertów jest gotów odpowiedzieć na Twoje pytania, dostosować ofertę do Twoich potrzeb i wesprzeć Cię w osiągnięciu sukcesu.

Wykorzystaj potencjał technologii już dziś, by zwiększyć efektywność, rozwijać biznes i zadbać o bezpieczeństwo swoich danych.

zespół
theme-ico